WinBuild 3896 doesnt seem to want to start


#1

Windows 10, Build 3896 doesnt seem to work. Previous version worked fine. this was after clearing cache and settings as well.

There is nothing in the logs to indicate a crash, but it does start up although the window never opens.


#2

@Meninthal The last half dozen or so lines from the log file may help narrow down where it’s got up to / what it’s got stuck on.


#3
[01/12 10:16:15] [WARNING] Couldn't open bookmarks file for reading
[01/12 10:16:15] [DEBUG] Rolled log file: "C:/Users/Matti/AppData/Local/High Fidelity/Interface/Logs/hifi-log_10.0.0.2_2016-01-12_10.16.15.txt"
[01/12 10:16:15] [DEBUG] AccountManager URL for authenticated requests has been changed to https://metaverse.highfidelity.com
[01/12 10:16:15] [DEBUG] Logging activity "launch"
[01/12 10:16:15] [DEBUG] No valid access token present. Bailing on invoked request to "/api/v1/user_activities" that requires authentication
[01/12 10:16:15] [DEBUG] AssetClient disk cache setup at "C:/Users/Matti/AppData/Local/High Fidelity/Interface" (size: 10 GB)
[01/12 10:16:15] [DEBUG] input  device: "Microphone (Samson C01U              )"
[01/12 10:16:15] [DEBUG] DEBUG [ "Microphone (Samson C01U              )" ] [ "Microphone (Samson C01U              )" ]
[01/12 10:16:15] [DEBUG] The default audio input device is "Microphone (Samson C01U              )"
[01/12 10:16:15] [DEBUG] The audio input device  "Microphone (Samson C01U              )" is available.
[01/12 10:16:15] [DEBUG] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm")
[01/12 10:16:15] [DEBUG] The desired audio format is not supported by this device
[01/12 10:16:15] [DEBUG] The format to be used for audio input is QAudioFormat(48000Hz, 16bit, channelCount=1, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm")
[01/12 10:16:15] [DEBUG] Attemping to create a resampler for input format to network format.
[01/12 10:16:15] [DEBUG] output  device: "Speakers (ASUS Xonar Essence STX Audio Device)"
[01/12 10:16:15] [DEBUG] QHostInfo lookup result for "stun.highfidelity.io" with lookup ID 1 is "54.67.22.242"
[01/12 10:16:15] [DEBUG] Sending intial stun request to stun.highfidelity.io
[01/12 10:16:15] [DEBUG] DEBUG [ "Speakers (ASUS Xonar Essence STX Audio Device)" ] [ "Speakers (ASUS Xonar Essence STX Audio Device)" ]
[01/12 10:16:15] [DEBUG] The default audio output device is "Speakers (ASUS Xonar Essence STX Audio Device)"
[01/12 10:16:15] [DEBUG] The audio output device  "Speakers (ASUS Xonar Essence STX Audio Device)" is available.
[01/12 10:16:15] [DEBUG] The desired format for audio I/O is QAudioFormat(24000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm")
[01/12 10:16:15] [DEBUG] The desired audio format is not supported by this device
[01/12 10:16:15] [DEBUG] The format to be used for audio output is QAudioFormat(48000Hz, 16bit, channelCount=2, sampleType=SignedInt, byteOrder=LittleEndian, codec="audio/pcm")
[01/12 10:16:15] [DEBUG] Attemping to create a resampler for network format to output format.
[01/12 10:16:15] [DEBUG] Output Buffer capacity in frames:  3

#5

Comparing against my program log after a successful start-up it looks pretty much the same …

QHostInfo lookup result for “stun.highfidelity.io” with lookup ID 1 is “54.67.22.242”
… Mine occurs a bit later on, but not surprising as my current Internet connection is, poor (to put it politely).

Lines from my log that occur immediately after where yours leave off…
[01/12 21:26:05] [DEBUG] Generated 2048-bit RSA key-pair. Storing private key and uploading public key.
[01/12 21:26:06] [DEBUG] Waiting for inital public socket from STUN. Will not send domain-server check in.
[01/12 21:26:06] [DEBUG] GL Version: “4.1.0 NVIDIA 361.43”
[01/12 21:26:06] [DEBUG] GL Shader Language Version: “4.10 NVIDIA via Cg compiler”
[01/12 21:26:06] [DEBUG] GL Vendor: “NVIDIA Corporation”
[01/12 21:26:06] [DEBUG] GL Renderer: “GeForce GTX 680M/PCIe/SSE2”
[01/12 21:26:06] [DEBUG] GL Version: “4.1.0 NVIDIA 361.43”
[01/12 21:26:06] [DEBUG] GL Shader Language Version: “4.10 NVIDIA via Cg compiler”
[01/12 21:26:06] [DEBUG] GL Vendor: “NVIDIA Corporation”
[01/12 21:26:06] [DEBUG] GL Renderer: “GeForce GTX 680M/PCIe/SSE2”
[01/12 21:26:06] [DEBUG] Created Display Window.
[01/12 21:26:06] [DEBUG] GL Version: “4.1.0 NVIDIA 361.43”
[01/12 21:26:06] [DEBUG] GL Shader Language Version: “4.10 NVIDIA via Cg compiler”
[01/12 21:26:06] [DEBUG] GL Vendor: “NVIDIA Corporation”
[01/12 21:26:06] [DEBUG] GL Renderer: “GeForce GTX 680M/PCIe/SSE2”
[01/12 21:26:06] [DEBUG] Status: Using GLEW 1.10.0
[01/12 21:26:06] [DEBUG]
[01/12 21:26:06] [DEBUG] V-Sync is ON
[01/12 21:26:06] [DEBUG]

But then I was already logged in.

Logging out then trying to start up Interface after generates crash, even after choosing “Reset all my settings” in the “you crashed last run” dialog box.


#6

I installed Windows build 3891 and logged in then exited. Then installed Windows build 3896 but it still crashed at start-up.

I then installed Windows build 3891 again and deleted cache and .ini files and logged in then exited. Then installed Windows build 3896 and it started up OK.


#7

Crash call stack…

 	Qt5Qml.dll!0000000072e01c70()	Unknown
 >	Interface.exe!OffscreenQmlSurface::load(const QUrl & qmlSource, std::function<void __cdecl(QQmlContext *,QObject *)> f) Line 379	C++
 	interface.exe!OffscreenUi::show(const QUrl & url, const QString & name, std::function<void __cdecl(QQmlContext *,QObject *)> f) Line 134	C++
 	interface.exe!LoginDialog::show(std::function<void __cdecl(QQmlContext *,QObject *)> f) Line 22	C++
 	interface.exe!DialogsManager::showLoginDialog() Line 65	C++
 	Qt5Core.dll!00000000722db287()	Unknown
 	interface.exe!AccountManager::checkAndSignalForAccessToken() Line 358	C++
 	interface.exe!AccountManager::qt_static_metacall(QObject * _o, QMetaObject::Call _c, int _id, void * * _a) Line 215	C++
 	Qt5Core.dll!00000000722df94a()	Unknown
 	Qt5Widgets.dll!0000000072785b96()	Unknown
 	Qt5Widgets.dll!0000000072784595()	Unknown
 	Qt5Core.dll!00000000722bc4e8()	Unknown
 	Qt5Core.dll!00000000722be144()	Unknown
 	qwindows.dll!00007ffa26e3096f()	Unknown
 	Qt5Core.dll!0000000072301ccc()	Unknown
 	[External Code]	
 	Qt5Core.dll!0000000072301389()	Unknown
 	qwindows.dll!00007ffa26e3089e()	Unknown
 	Qt5Core.dll!00000000722bcae2()	Unknown
 	interface.exe!RunningScriptsWidget::setRunningScripts(const QStringList & list) Line 167	C++
 	interface.exe!RunningScriptsWidget::RunningScriptsWidget(QWidget * parent) Line 66	C++
 	interface.exe!Application::Application(int & argc, char * * argv, QElapsedTimer & startupTimer) Line 618	C++
 	interface.exe!main(int argc, const char * * argv) Line 103	C++
 	[External Code]

#8

Ill get more details once I get back home. Sorry for the double post earlier :slight_smile:


#9

Heh … I’ve confirmed that Windows build 3895 works OK but build 3896 crashes at start-up if you’re not logged in, and I’ve sent a message to the HiFi devs ready for them when they wake up : ) … Probably don’t need any more details at the moment.


#10

Thanks guys. Fix on the way.