Yet another of what is probably a noob question but...about these updates


#1

So, since my laptop sounds like it’s about to lift off with the fan running when I run interface, I installed interface on another machine tonight when I got home from work. I was surprised when it told me that the server version was incompatible with my client at login. I assumed that was a good explanation for all my entities missing too. One thing I hadn’t considered was that I would be wearing the default, robot avatar again…I assumed that was saved on the server and not in Interface. Wrong assumption?

Anyway, I found that interface was 13 versions behind on my laptop (2948) while the latest I installed on the other machine is 2961. I’ve determined that 2953 is the last version that works with my current server stack. I didn’t see an announcement about needing to update the Stack Manager, nor could I find the version number in the source code (I’m running ubuntu) to know if I really needed to update to the version currently at github. So, figuring I had nothing to lose, I cloned the repository (using git clone https://github.com/highfidelity/hifi.git), remade everything and relaunched the server. I’m still getting the message that interface is incompatible with the server unless I fall back to 2948. Did I miss an announcement and how do I determine which version of the stack manager and servers I’m running? …and is it updated as frequently as interface is?


#2

Restarting the stack manager on other os pulls up the latest version of the server files that is uptodate with the client.
However if the using Ubuntu compiling from the latest master branch should pull up the latest release version both client and servers

If the client version does not match the server versions requirement you usually are not connected. Which ends up with seeing nothing

It’s odd though that the building from the master didn’t seem to work

Have you tried other domains while using the latest client?


#3

Thank you. Yes, with the latest client, the other domains are fine so it seems that my stack is out of sync and it’s not a problem with the client. I’ll try rebuilding that from source again. Is there a command that will return the version number(s) or a source file to peek into that lists the build number?


#4

and…as I sit here waiting for it to finish building…which is taking much, much longer, I’m realizing that I neglected to do a ‘make clean’ last night. So, it was a noob issue :smiley:

Second lesson learned is that when I login using interface, I shouldn’t accept and install an update unless I’m also ready to rebuild the stack - they go hand in hand.

…except that I’m still out of sync :frowning: …but I now see the problem. git is creating a new ‘hifi’ directory but I’ve been rebuilding the same ‘old’ one. tsk tsk…

update to the update: So, I rebuilt with a fresh and clean hifi directory after putting a copy of my existing ‘build’ directory inside of that because I was thinking that I need the ‘old’ settings (backup info, domain settings, etc) but after all that am still getting the server wrong version message. I have errands to do now but upon returning, will build it all again, without my ‘old’ build directory and see what happens. After that, I’m out of ideas again.


#5

I also have updated today first time my place.

  1. I have stopped my screens.
  2. I have renamed my old compile folder and removed the hifi folder.
  3. I have cloned the hifi git and build all new.
  4. I have put the old resources folder in the assignment-client folder.

After this all things were back at my place. I don’t know, if I really have to remove all of my old build. Maybe the build would also work, if I let stay the compile folder. Maybe it would look, what must be made new.


#6

well…I tried and tried and tried…until I ran out of disk space :smiley: Finally cloned from git, did a pull (said I was up to date) and logged in without restoring any resources and I did NOT get the notice that I was out of sync (yay!) …but of course, nothing was there so I logged out, created the resources folder for the assignment-client and copied only the models.json.gz file from my old build then logged back in. It took a bit but as I was about to give up, my entities appeared. However, they were not where I left them. I went to another domain and came back to mine (auralia) by name and everything was way below me. Then tried a bookmark that I had created before with the same result. Finally, while standing on solid hmmm…board? I created a new bookmark. tp’d out and came back using that bookmark and I landed with my feet on the ground (as I left) Success I guess…

…however, now I’m getting a prompt that there is a new update available. I think I’ll sit this one out for a while :smile:

Of course, I only have more questions though…such as where is the domain server info stored? …since this was a fresh build, how did it know this is ‘Auralia’ ? What if I were building another for a second domain? When I went to the domain website, it was already connected to my account and had the extra backup that I had previously done, still configured.

On a different subject when I go to the ‘security’ page (https://metaverse.highfidelity.com/user/domains ) it says I have no domains yet on the places page, ( https://metaverse.highfidelity.com/user/places ) the domain I bought does show there and points to the domain-server I’m running.


#7

You just came in during a bout of updates.
Generally we can update the interface everyday for weeks without having to recompile the server(domain).
But recently there has been several upgrades of the domain server code causing the “incompatible” warning and the need for updating the server stack a couple of times in a row.

Please be confident that updating your interface does not often demand updating the server code.


#8

The info is stored in the Config.json.


#9

Thanks for your reply, Adrian…that makes much more sense to me. This was my first domain ‘update’ and of course, assumed I was doing something wrong - well, I was but even after I got it straight, it seemed wrong…if that makes sense :smiley:

Anyway, I’m sure the next will go much more smoothly for me now that I have this first one under my belt.


#10

And perhaps the last update of this thread…just wanted to add that I successfully jumped through 21 updates to interface and one git pull to update the domain server with no issues whatsoever :slight_smile: …not that I’m doing anything extensive enough in world yet to have any issues that can’t easily be attributed to my inexperience here, but the update process I think I have grasped now :smiley: